#1
  1. No Profile Picture
    Contributing User
    SEO Chat Explorer (0 - 99 posts)

    Join Date
    Nov 2003
    Location
    Miami FL
    Posts
    37
    Rep Power
    16

    Question Googler, anybody, can you tell me what's wrong?


    Hi, I am new to this board and to SEO in general. I noticed you were helpful on the boards so I thought I'd ask for some advice, although anyone with knowledge is free to help me out.

    I have recently submitted our site at http://4womenoftheworld.com to Google, and the Paid Inclusion services at I need Hits, Insite, Ah-ha and Yahoo.

    Despite being included in the directories of these engines, I have ZERO rankings for my keywords. I positioned the site to the best of my knowledge to rank high for keywords "Brazilian Girls" and "Rio de Janeiro" among others.

    The search results for these keywords are far less relevant to the keywords than my site, so I can't figure out what is wrong. I just completed the Pay for inclusion services a few days ago so perhaps these things take several weeks or months to rank my site appropriately?

    I would greatly appreciate it if anyone would look at my site, type in Brazilian Girls or Rio de Janeiro into any search engine and witness that we do NOT appear anywhere in the results. Please look at my site and tell me if you see anything obviously wrong.

    Thanks again. I appreciate all the help I have received on this board.

    Kindest Regards,

    Dan
  2. #2
  3. Modsky
    SEO Chat Skiller (1500 - 1999 posts)

    Join Date
    May 2003
    Location
    canada
    Posts
    1,793
    Rep Power
    18
    Dan, Im sorry noone has replied yet this should get you started http://www.seo-guy.com/tutorial.html Also you really want to consider applying a filter to your pages to mod rewrite them into parsable query strings for Google there are lots around off the shelf that apply to asp Also ou have almost all of your text if not all in images, that kills any chance you will EVER have to rank anywhere. one big image with a title attached to it isnt relevant at all, google does not spider images they are invisible except for alt and title tags so you really have some work to do
    Cheers
    And btw feel free to PM if you need anything

Similar Threads

  1. Please check what has gone wrong?
    By Maneesh in forum Public Site Reviews
    Replies: 3
    Last Post: Sep 1st, 2003, 04:50 AM
  2. What am I doing wrong??
    By Sincerely in forum Public Site Reviews
    Replies: 4
    Last Post: Jul 28th, 2003, 11:36 AM
  3. Someone PLEASE help explain: where have I gone wrong
    By asalko in forum Google Optimization
    Replies: 1
    Last Post: Jun 16th, 2003, 03:23 PM
  4. Googler visited my site briefly
    By J A Todd in forum Google Optimization
    Replies: 2
    Last Post: May 29th, 2003, 05:51 PM
  5. I Don't Think This Is The Dance...I could be wrong though
    By Old Fat Guy in forum Google Optimization
    Replies: 13
    Last Post: May 6th, 2003, 09:29 PM

IMN logo majestic logo threadwatch logo seochat tools logo