Thread: Analytics Issue

    #1
  1. Contributing User
    SEO Chat Discoverer (100 - 499 posts)

    Join Date
    May 2017
    Posts
    256
    Rep Power
    380

    Analytics Issue


    Just looking at a new site that gets around 1000 visitors a month but the bounce rate is non-existent, about 1.2%.

    I've seen this before where they have two tracking ID's on the site that cause multiple page views so you never technically get a bounce but this is a little different.

    They have one code:

    <script>
    (function(i,s,o,g,r,a,m){i['GoogleAnalyticsObject']=r;i[r]=i[r]||function(){
    (i[r].q=i[r].q||[]).push(arguments)},i[r].l=1*new Date();a=s.createElement(o),
    m=s.getElementsByTagName(o)[0];a.async=1;a.src=g;m.parentNode.insertBefore(a,m)
    })(window,document,'script','//www.google-analytics.com/analytics.js','ga');
    ga('create', 'UA-85374308-1', 'auto');
    ga('require', 'displayfeatures');
    ga('send', 'pageview');

    window.google_analytics_uacct = "UA-85374308-1";
    </script>

    And another:

    <!-- Google Analytics: change UA-XXXXX-X to be your site's ID. -->
    <script>
    (function(b,o,i,l,e,r){b.GoogleAnalyticsObject=l;b[l]||(b[l]=
    function(){(b[l].q=b[l].q||[]).push(arguments)});b[l].l=+new Date;
    e=o.createElement(i);r=o.getElementsByTagName(i)[0];
    e.src='//www.google-analytics.com/analytics.js';
    r.parentNode.insertBefore(e,r)}(window,document,'s cript','ga'));
    ga('create','UA-XXXXX-X','auto');ga('send','pageview');
    </script>

    Having these two on the site is the only reason I can think of for the bounce rate, presumably removing this would solve the issue but I didn't think a generic code like the second one would cause this.
  2. #2
  3. No Profile Picture
    Contributing User
    SEO Chat Discoverer (100 - 499 posts)

    Join Date
    Mar 2017
    Location
    Sydney, Australia
    Posts
    259
    Rep Power
    509
    Hi IvanDrago,
    I've not encountered this problem so can only work on theory like you.

    The thought that goes though my mind is how G can only track bounce rates if there are 2 site page clicks. Could the presence of two UA codes fool Analytics into thinking that most visits come from one UA that has no second click because the second clicks are seen as the second UA code?

    Purely speculation...
  4. #3
  5. Contributing User
    SEO Chat Discoverer (100 - 499 posts)

    Join Date
    May 2017
    Posts
    256
    Rep Power
    380
    Originally Posted by JohnAimit
    Hi IvanDrago,
    I've not encountered this problem so can only work on theory like you.

    The thought that goes though my mind is how G can only track bounce rates if there are 2 site page clicks. Could the presence of two UA codes fool Analytics into thinking that most visits come from one UA that has no second click because the second clicks are seen as the second UA code?

    Purely speculation...
    Seems to be possible.

    We encountered the same issue about a month ago when a new client had two different UA codes on their site with a bounce rate of around 0.5%, as soon as we removed the defunct one the levels returned to a normal rate, about 40%.

    Even when you drill down into each individual session on this new site, every page view is shown twice, even when they've spent 00:00 seconds on the site.

    At this point we have access to their Analytics but nothing else so it hasn't been removed, but this is the only reason I can think of that could be causing it.

    A few people also mentioned this could be a shady agency trick, possibly to make the stats look better to the client or as a black hat technique to manipulate the rankings.
  6. #4
  7. SeoRaptor
    SEO Chat Adventurer (500 - 999 posts)

    Join Date
    Mar 2016
    Location
    France, Saint-Etienne
    Posts
    994
    Rep Power
    1703
    The thought that goes though my mind is how G can only track bounce rates if there are 2 site page clicks.
    This is not exactly the case, any Webdesigner could actually cheat to get a lower bounce rate even getting it to 0%.

    Bounce rate is not only impacted by clicks on pages but also by events, so if you have any kind of event triggering on the page, the visit is not counted as a bounce.

    I've seen this before where they have two tracking ID's
    Whatever the reason might be this is a very bad practice, if you want to provide data to another user you should definitively use the user management option inside the analytics account.

    Comments on this post

    • JohnAimit agrees
    Last edited by Pierre Benneton; Sep 27th, 2017 at 04:59 AM.
    Owner of Bennetonable - "My opinions are my own - Feel free to disagree & think above the fold."
    Need a quick analysis > Free SEO grader Beta
  8. #5
  9. Contributing User
    SEO Chat Discoverer (100 - 499 posts)

    Join Date
    May 2017
    Posts
    256
    Rep Power
    380
    Originally Posted by Pierre Benneton
    This is not exactly the case, any Webdesigner could actually cheat to get a lower bounce rate even getting it to 0%.

    Bounce rate is not only impacted by clicks on pages but also by events, so if you have any kind of event triggering on the page, the visit is not counted as a bounce.



    Whatever the reason might be this is a very bad practice, if you want to provide data to another user you should definitively use the user management option inside the analytics account.
    I agree, which is why I think the double page views is causing the data to be skewed.
  10. #6
  11. No Profile Picture
    Contributing User
    SEO Chat Discoverer (100 - 499 posts)

    Join Date
    Feb 2017
    Posts
    115
    Rep Power
    279
    Any chance I could PM one of you to walk me through how to resolve this issue? I think I have the same exact problem as Ivan...man this client keeps having issue after issue come up. Their bounce rate is 0.47%....
  12. #7
  13. Contributing User
    SEO Chat Discoverer (100 - 499 posts)

    Join Date
    May 2017
    Posts
    256
    Rep Power
    380
    Originally Posted by Digital Marketeer
    Any chance I could PM one of you to walk me through how to resolve this issue? I think I have the same exact problem as Ivan...man this client keeps having issue after issue come up. Their bounce rate is 0.47%....
    With the first site we saw it on, all we had to do was remove the old code and everything returned to normal.

    Can't think of a single reason you would need two UA codes.
  14. #8
  15. No Profile Picture
    Contributing User
    SEO Chat Discoverer (100 - 499 posts)

    Join Date
    Feb 2017
    Posts
    115
    Rep Power
    279
    Actually, this is the only code they have:

    <script>
    (function(i,s,o,g,r,a,m){i['GoogleAnalyticsObject']=r;i[r]=i[r]||function(){
    (i[r].q=i[r].q||[]).push(arguments)},i[r].l=1*new Date();a=s.createElement(o),
    m=s.getElementsByTagName(o)[0];a.async=1;a.src=g;m.parentNode.insertBefore(a,m)
    })(window,document,'script','https://www.google-analytics.com/analytics.js','ga');
    ga('create', 'UA-80994298-1', 'auto');
    ga('send', 'pageview');
    </script>
    <!-- End GA Code -->

    Could something else be causing the low bounce rate?
  16. #9
  17. Contributing User
    SEO Chat Discoverer (100 - 499 posts)

    Join Date
    May 2017
    Posts
    256
    Rep Power
    380
    Originally Posted by Digital Marketeer
    Actually, this is the only code they have:

    <script>
    (function(i,s,o,g,r,a,m){i['GoogleAnalyticsObject']=r;i[r]=i[r]||function(){
    (i[r].q=i[r].q||[]).push(arguments)},i[r].l=1*new Date();a=s.createElement(o),
    m=s.getElementsByTagName(o)[0];a.async=1;a.src=g;m.parentNode.insertBefore(a,m)
    })(window,document,'script','https://www.google-analytics.com/analytics.js','ga');
    ga('create', 'UA-80994298-1', 'auto');
    ga('send', 'pageview');
    </script>
    <!-- End GA Code -->

    Could something else be causing the low bounce rate?
    Have you recorded the session using tag assistant to see if there's any errors?
  18. #10
  19. No Profile Picture
    Contributing User
    SEO Chat Discoverer (100 - 499 posts)

    Join Date
    Feb 2017
    Posts
    115
    Rep Power
    279
    I have not...Tag Manager isn't even set up. Guess I'll have to do it.
  20. #11
  21. Contributing User
    SEO Chat Discoverer (100 - 499 posts)

    Join Date
    May 2017
    Posts
    256
    Rep Power
    380
    Originally Posted by Digital Marketeer
    I have not...Tag Manager isn't even set up. Guess I'll have to do it.
    Tag Assistant is just a plugin for Chrome.

    Just lets you see what requests are being sent on any particular page.
  22. #12
  23. No Profile Picture
    Contributing User
    SEO Chat Discoverer (100 - 499 posts)

    Join Date
    Feb 2017
    Posts
    115
    Rep Power
    279
    Gotcha...I wasn't aware of that plugin...I thought you just meant Google Tag Manager. I'll download the plugin and let you know.
  24. #13
  25. No Profile Picture
    Contributing User
    SEO Chat Discoverer (100 - 499 posts)

    Join Date
    Feb 2017
    Posts
    115
    Rep Power
    279
    Looks like the code is outside of the <head> tag, but that's the only error tag assistant found. Could that be causing the issue?
  26. #14
  27. Contributing User
    SEO Chat Discoverer (100 - 499 posts)

    Join Date
    May 2017
    Posts
    256
    Rep Power
    380
    Originally Posted by Digital Marketeer
    Looks like the code is outside of the <head> tag, but that's the only error tag assistant found. Could that be causing the issue?
    Does the site use iFrames at all?

    Could be causing multiple page views if so.

    Are there any events set up that could be causing an action to happen?
  28. #15
  29. No Profile Picture
    Contributing User
    SEO Chat Discoverer (100 - 499 posts)

    Join Date
    Feb 2017
    Posts
    115
    Rep Power
    279
    No events set up...they literally have nothing set up...but iFrames are being used. I just sent you a PM.

Similar Threads

  1. Google analytics issue
    By Rashmi Kawale in forum New User SEO Questions and Answers
    Replies: 1
    Last Post: Nov 30th, 2015, 10:26 AM
  2. Google Analytics Issue
    By mtw in forum Google Optimization
    Replies: 15
    Last Post: Nov 3rd, 2010, 11:20 AM
  3. Google Analytics Tracking Issue
    By anandmistry in forum Analytics Analysis
    Replies: 0
    Last Post: Feb 25th, 2010, 11:45 PM
  4. Strange analytics issue. 'iceurlflag'
    By realityhack in forum Analytics Analysis
    Replies: 4
    Last Post: Jun 24th, 2009, 08:14 AM
  5. Google Analytics Report:Zero-Second Issue
    By Rick_001 in forum Google Optimization
    Replies: 0
    Last Post: Jan 24th, 2008, 05:28 AM

IMN logo majestic logo threadwatch logo seochat tools logo