#1
  1. No Profile Picture
    Newbie
    SEO Chat Explorer (0 - 99 posts)

    Join Date
    Oct 2017
    Posts
    6
    Rep Power
    0

    Serve resources from a consistent URL


    Hi,

    Not sure if this is the right place to post this on but does relate to google analytics.

    I ran a report on GTmetrix and had the following issue occur:

    The following resources have identical contents, but are served from different URLs. Serve these resources from a consistent URL to save 1 request(s) and 35.2KiB.

    http://www.google-analytics.com/analytics.js
    https://www.google-analytics.com/analytics.js
    The following resources have identical contents, but are served from different URLs. Serve these resources from a consistent URL to save 1 request(s) and 108B.

    https://adservice.google.ca/adsid/integrator.js?domain=www.humveeuk.com
    https://adservice.google.com/adsid/integrator.js?domain=www.humveeuk.com
    The following resources have identical contents, but are served from different URLs. Serve these resources from a consistent URL to save 1 request(s) and 43B.

    http://ssl.gstatic.com/s2/oz/images/stars/po/bubblev1/border_3.gif
    https://ssl.gstatic.com/s2/oz/images/stars/po/bubblev1/border_3.gif



    I'm using wordpress and have the Monster Insight plugin installed with the google analytics code implemented on there. I don't have the code placed anywhere else so don't know why it is saying there are two urls on my webiste.

    Would really appreciate it if someone could shed some light onto this.

    Many thanks
    Becky

    PS. I'm very basic with this website stuff so a simply solution would be great!
  2. #2
  3. No Profile Picture
    Moderator
    SEO Chat Good Citizen (1000 - 1499 posts)

    Join Date
    Sep 2016
    Location
    USA
    Posts
    1,363
    Rep Power
    2484
    It may have something to do with this.... I dunno....

  4. #3
  5. No Profile Picture
    Newbie
    SEO Chat Explorer (0 - 99 posts)

    Join Date
    Oct 2017
    Posts
    6
    Rep Power
    0
    Originally Posted by KnowOneSpecial
    It may have something to do with this.... I dunno....

    Wow thanks, how did you get that message? I have never seen it before. Very worrying! I thought using wordpress was pretty straight forward! Yet another thing to sort out!! Thank you for bringing this to my attention.
  6. #4
  7. Dinosaur
    SEO Chat Genius (4000 - 4499 posts)

    Join Date
    Jun 2011
    Location
    UK
    Posts
    4,116
    Rep Power
    6553
    The issue is somewhere your serving both the HTTP and HTTPS versions which is making the site not secure.
    If your not comfortable editing the code to prevent this I believe there is a plugin to only server https assets, I dont think they correct the issue but prevent you from serving the incorrect version.
    I cant check at the moment but try doing a plugin search for "always https" and hopefully it will find you something.
    Owner of Page Explorer the page onsite SEO checker
    Useful Tools: Site Crawler: Screaming Frog | Free SSL: Cloudflare
  8. #5
  9. No Profile Picture
    Newbie
    SEO Chat Explorer (0 - 99 posts)

    Join Date
    Oct 2017
    Posts
    6
    Rep Power
    0
    Originally Posted by Chedders
    The issue is somewhere your serving both the HTTP and HTTPS versions which is making the site not secure.
    If your not comfortable editing the code to prevent this I believe there is a plugin to only server https assets, I dont think they correct the issue but prevent you from serving the incorrect version.
    I cant check at the moment but try doing a plugin search for "always https" and hopefully it will find you something.
    Thank you.
    I checked my cpanel and it stated my ssl certificate had expired so have renewed that. It is still saying that my website is not secure so will have a look into the plugin to only allow it show the https version.

    I've also asked my web hosting company to have a look at it, as you can probably tell I have no idea what I'm doing.

    Thank you for your help.

    I've also noticed, relating to the first query, that when I turn adsense ads off on my homepage the, "serve resources from a consistent url" error is resolved. Am I implementing my ads on the website wrong or is this a common error with adsense? I copy and paste the html code into a html box on the website.
  10. #6
  11. No Profile Picture
    Moderator
    SEO Chat Good Citizen (1000 - 1499 posts)

    Join Date
    Sep 2016
    Location
    USA
    Posts
    1,363
    Rep Power
    2484
    Originally Posted by humveeuk
    when I turn adsense ads off on my homepage the, "serve resources from a consistent url" error is resolved.
    This error will most likely resolve itself when you resolve your http / https problems.

    Just a hunch...

Similar Threads

  1. Is there any consistent way of word tagging?
    By DarekSobiecki in forum Search Engine Optimization
    Replies: 6
    Last Post: Nov 11th, 2012, 01:58 PM
  2. Search result in Google not consistent
    By krisanta_khryss in forum SEO Help (General Chat)
    Replies: 1
    Last Post: Sep 2nd, 2008, 01:40 AM
  3. Policy for anchor keywords - consistent or variable ?
    By fistofpeanuts in forum Google Optimization
    Replies: 3
    Last Post: Sep 12th, 2007, 04:41 PM
  4. Sony seen needing consistent PS3 strategy (Reuters)
    By RSS_News_User in forum Technology News
    Replies: 0
    Last Post: Sep 7th, 2007, 10:05 AM
  5. Service aims for consistent Web browsing (AP)
    By RSS_News_User in forum Technology News
    Replies: 0
    Last Post: Apr 25th, 2007, 04:03 PM

IMN logo majestic logo threadwatch logo seochat tools logo