#1
  1. Contributing User
    SEO Chat Discoverer (100 - 499 posts)

    Join Date
    May 2010
    Posts
    153
    Rep Power
    67

    WMT "Links to Your Site"


    Bad links pointing at page.

    Page internally redirected (301) to new page (stupidly)

    I deleted and 404'd old page and removed the 301.

    Links are still appearing in Webmaster Tools after 6 months to the new page:
    Via this intermediate link:http://site.com/old-404d-deleted-page/

    I'm not worrying, just curious whether it's just WMT lagging behind, or if these links are still a part of the link graph used by Google?
  2. #2
  3. No Profile Picture
    cbp
    Contributing User
    SEO Chat Adventurer (500 - 999 posts)

    Join Date
    Oct 2003
    Posts
    910
    Rep Power
    253
    If the links exists and still points to the site, then why would it not be showing in the WMT?
  4. #3
  5. Contributing User
    SEO Chat Discoverer (100 - 499 posts)

    Join Date
    May 2010
    Posts
    153
    Rep Power
    67
    Originally Posted by cbp
    If the links exists and still points to the site, then why would it not be showing in the WMT?
    WMT is still showing it as pointing to the new page via a 301 redirect. This is despite me having removed the 301 and 404ing the old page.

    Just interested in whether there is a delay in WMT showing latest information, or whether it is still yet to be removed from the link graph.
  6. #4
  7. rod@missionop.com
    SEO Chat Mastermind (5000+ posts)

    Join Date
    Mar 2003
    Location
    Palm Beach Gardens FL 33410
    Posts
    15,163
    Rep Power
    1948
    Originally Posted by cbp
    If the links exists and still points to the site, then why would it not be showing in the WMT?
    Remember a PERMANENT 301 redirect is suppose to be permanent so it can take forever and in general will update about the same time as the PageRank Toolbar.
  8. #5
  9. No Profile Picture
    Banned
    SEO Chat Explorer (0 - 99 posts)

    Join Date
    Jul 2014
    Posts
    16
    Rep Power
    0
    I have a problem with just this. Yesterday Google Webmaster Tools showed me that I had roughly 1000 links to my site. Today, it says "No data available." People who enters my site from Google have also dropped from around 40, to 0. Any ideas?

Similar Threads

  1. Do links fm "site targeted" google ad campaigns count?
    By AnythingOn in forum Link Development
    Replies: 2
    Last Post: Jul 12th, 2006, 12:45 AM
  2. Do links from "site targeted" google ad campaigns work?
    By AnythingOn in forum Link Development
    Replies: 0
    Last Post: Jul 11th, 2006, 11:48 PM
  3. Links on "Home page" links vs links on "links pages"
    By freewr in forum Link Development
    Replies: 2
    Last Post: Apr 12th, 2006, 10:29 AM
  4. PDF files links from your site consider "content"?
    By maha in forum Google Optimization
    Replies: 8
    Last Post: Dec 10th, 2005, 04:16 AM
  5. Replies: 6
    Last Post: Nov 18th, 2004, 07:32 AM

IMN logo majestic logo threadwatch logo seochat tools logo