#1
  1. No Profile Picture
    Registered User
    SEO Chat Explorer (0 - 99 posts)

    Join Date
    Jan 2009
    Posts
    10
    Rep Power
    0

    Links to your site in GWT - removed manually from other site but still in GWT


    I have read that it takes a long time for the Links to Your Site in GWT to update. But it has been several months. Here is the situation.

    Some history, feel free to skip this paragraph.

    The site that I want to restore Google ranking to has been online since 2000. It performed #1 result for my terms from then until around 2007. With new competition and continuous google changes and a few mistakes and hard lessons learned, I still maintained results within the first three pages after 2007. The site went through a few revisions, from straight up HTML, to e107 to wordpress (current). Really positive results started to occur over the summer this year (1st and second page rankings for competitive terms). Started to feel like the old days again.

    Then I was hit with an algorithmic change on Sep 28 or thereabouts. Dropped well out of the first 30 pages if not more for just about everything minus my homepage site title and a couple well linked pages.

    I have gone over everything with a fine toothed comb, made plenty of quality changes and I always come back to what I suspected was the problem from the start. One of my other websites (Site B) was linking to two or three pages on the problem site (A), and these links were at the top of every page of Site B. Site B performs very well in Google, #1 for the terms I want, and generally high for relevant other terms. But GWT was reporting 800,000 links from Site B to Site A. I hadn't been paying attention to SEO so much until the traffic drop, but when I saw the information about sitewide links, over optimization, etc, I immediately removed the links at the top of Site B.

    It has been since the end of September, and now there are about 460,000 links still being reported. Of course in reality there are currently ZERO since that time.

    I experimented with some other links at the top of Site B. I linked to some newer HTML sites I have that really didn't have much significance in google. At first they showed strong results in google but then faded away after a few days. I removed the links and then they return really strong in google, and these are pretty new sites. One is a year old and the other only a couple months. They have a handful of other IBLs which help, but Site A has a pretty strong link profile and solid content. So when Site B produces 800,000 sitewide links I can see how that's an obvious problem and my experiments confirmed that.

    I believe this is the source of my problem. I just want to know how much longer I can expect to wait for this report to reflect reality and if there is any way to expedite the update.
  2. #2
  3. SEO Since 97
    SEO Chat Mastermind (5000+ posts)

    Join Date
    Mar 2011
    Location
    Arizona
    Posts
    5,274
    Rep Power
    1965
    I believe Sept. 28th was a Panda refresh and a touch of an EMD (exact match domain, with poor content)...anyway they both had to do with poor content, on-page optimization and so on...do you have any duplicate content between these sites? I think you might be looking in the wrong area, if it was link related, you would have noticed the problem early 2012...I think it was March, somewhere around there.
  4. #3
  5. No Profile Picture
    Registered User
    SEO Chat Explorer (0 - 99 posts)

    Join Date
    Jan 2009
    Posts
    10
    Rep Power
    0
    I don't have any duplicate content among individual sites. As for dup content within the badly performing site, I had common wordpress duplicate issues which I resolved well before the traffic drop. AFAIK. I see no duplicate meta desc type messages in GWT when I had several thousand in the past. Proper noindex or nofollow so that various archive pages don't create dup content.

    There are 49 URL parameters that show up in GWT. I had set most of them to NO URLs, and just a couple days ago set all of them that way. I know I'm not restricting anything I want in google's index. 'replytocom' for example which is an obvious No URLs for a wordpress site. Some of the params are for a rotating banner script that I stopped using a few weeks ago. Some of them are various examples each of

    month_200908

    item_82_7

    default_0_56

    day_20080624

    which I suppose are wordpress related but I have everything noindexed (via an SEO plugin) except the front page, my posts, my pages, my category pages, and my tag pages (of which I use a handful of)

    There are some params that are like

    uaydwlfchsl
    or
    sossirlvovjxvhqe

    and I have no idea what that's about.

    I'm not going to mention my domains but let's say the badly performing one is ExactMatchDomain.com. Continuing the example my site title would be Exact Match Domain and it is the name of my site since 2000. If you search for "Exact Match Domain" my site comes up first still. I would assume that EMD update can't be the cause.. ?
    Last edited by mbuddha; Dec 11th, 2012 at 03:36 AM.

Similar Threads

  1. My site's last cache has been removed
    By Valex03 in forum Google Optimization
    Replies: 1
    Last Post: Jan 24th, 2011, 01:54 AM
  2. Could a site be removed for a certain keyword and not for others?
    By seo-top-ranked in forum Google Optimization
    Replies: 6
    Last Post: Nov 25th, 2009, 05:23 AM
  3. Why Google removed my “site links”, need your help
    By zahirshah in forum Google Optimization
    Replies: 13
    Last Post: Jul 7th, 2008, 05:47 AM
  4. Replies: 1
    Last Post: May 30th, 2008, 11:15 AM
  5. When does site get removed?
    By mharvey in forum Google Optimization
    Replies: 3
    Last Post: Aug 25th, 2005, 10:16 AM

IMN logo majestic logo threadwatch logo seochat tools logo