#1
  1. Contributing User
    SEO Chat Skiller (1500 - 1999 posts)

    Join Date
    May 2004
    Location
    Malta
    Posts
    1,980
    Rep Power
    89

    Arrow I know this has been asked before but I can't find it!!!


    I know I've seen this question before somewhere but I can't find it. Anyhoo, I cannot get Google to show any description for my sites.
    I've tried everything I have heard and seen about optimizing them for the Google bot: from the Robots.txt file to content, backlinks and so on.

    Now I turn to the experts I've been learning from for months to PLEEEEEZE! look at them and see if you can figure anything out.
    The sites are divers-supply.com and valuescuba.com

    I show all kinds of backwards links through everyone but Google, and this includes PR7 sites as well (ie. Mares.com).

    My logs show it crawls it all the time; both the freshbot and when back links were updated but you see what I've got? Just search google for
    the site names and you'll see what I mean.

    HELP!!!!
    Signed,
    Google-Gagged
    Last edited by GaryTheScubaGuy; Nov 1st, 2004 at 01:45 PM. Reason: no views

Similar Threads

  1. Google not showing a proper description
    By JesperDK in forum Google Optimization
    Replies: 1
    Last Post: Jul 1st, 2004, 09:38 AM
  2. Why won't google use my meta description?
    By cyphix in forum Google Optimization
    Replies: 7
    Last Post: Apr 8th, 2004, 07:58 PM
  3. Forcing Google to use description
    By Phoenix in forum Google Optimization
    Replies: 16
    Last Post: Sep 25th, 2003, 09:28 PM

IMN logo majestic logo threadwatch logo seochat tools logo